mastodon-1.5

mastodon 1.5r2の話だけど、heroku buildする際にgem install idn-ruby -v '0.1.0'みたいなerrorがでて、それは、libidn11-devというパッケージのインストールが必要みたいで、wgetするんだけど、しかし、herokuには元々libidnが入っているぽいのでよくわからない感じになって、.buildpacksを見てみると、URLがあるんだけど、それをheroku buildpacks:addするんだけど、やっぱり出来なくて、Aptfileを見てもlibidnはheroku-buildpack-aptでインストールする感じになっていて、よくわからない。

ちなみに、Aptfileはherokuのbuildpacksでインストールするパッケージを記述するファイル。herokuのbuildpacksは追加するとそれでビルドすることになる。必要なものは.bildpacksに書いてあるので、それをheroku buildpacks:addで追加すると有効になる。

結論として、libidn11-devの行をAptfileから削除してgit push heroku masterしたらいけた。

## mastodon 1.5
$ heroku run 'dpkg -l'
$ cat .buildpacks
$ heroku buildpacks:add --index 1 https://github.com/heroku/heroku-buildpack-apt

# error : gem install idn-ruby
# Aptfile -> libidn11-dev の行を削除してpush

$ heroku run rake db:migrate -a $app
$ heroku run rake assets:precompile -a $app
$ heroku ps:restart -a $app

参考

https://note.mu/west2538/n/ne52c57340555